chesapeake lt 16 launch

Finally finished my 1st boat, an lt16. Launched friday, and happy to say my nightmares that it would go round and round in circles and sink didn't materialise. In fact I was ecstatic with the way it handled.

If I was going to name it I'd call it "95%", as during the build I seemed to do 95% of everything perfectly, and messed up on the remaining 5%, but am very pleased with it, and it even fits on my car, well almost.

Thanks to everyone on the forum for the various hints and know how. Also thanks to the staff at CLC and shipping for rushing me those last minute bits and pieces I needed. I really enjoyed the build experience.

Was about to post pics, but am having problems getting them from my desktop to the message board, any hints ?





5 replies:

« Previous Post       List of Posts       Next Post »

RE: chesapeake lt 16 launch

Congratulations on finishing your first build and getting it in the water!

To post a picture, you first need to upload it somewhere accessible on the web... e,g, on your own website or somewhere like Flickr.When you can browse to it, click on the address bar and copy the URL. Then come backk here and in a post, click on the "insert/edit image" button and paste in the URL... e.g. this one is from CLC's own website...

Chesapeake 16LT


RE: chesapeake lt 16 launch

Well, it workd in spite of the extra forward slash in the URL !

RE: chesapeake lt 16 launch

This one is a bit smaller (40% of full size instead of 50%) and "alignment not set".

Chesapeake LT 16

RE: chesapeake lt 16 launch

Congrats on a successful build and happy shake down cruise!  Looking forward to the pics.

« Previous Post     List of Posts     Next Post »

Please login or register to post a reply.


Special Financing with Blispay

 CLC's Fall Kit Sale